Problem starting Tor Browser Bundle


Dec18
Hi,

I'm attempting to run the Tor Browser Bundle 2.3.25-10_en-US on 64-bit Windows 7 Home Premium SP1. I get as far as the Vidalia Control Panel telling me "Connected to the Tor network!" when the following error message shows up:



I've checked the process table (Firefox is not listed as running) and restarted the machine to no avail.

Hopefully someone more knowledgeable than I am about Tor (that would be just about anyone) can suggest a way to get it working.

Thanks in advance for any help.

Tom

Dec18
1) Try running firefox.exe with -no-remote switch.

2) Try editing Tor Browser\FirefoxPortable\FirefoxPortable.ini file:

AdditionalParameters=-no-remote
AllowMultipleInstances=true
DisableIntelligentStart=true
RunLocally=true
WaitForFirefox=false

I am not sure about what exactly IntelligentStart or RunLocally means, but playing with true/false could help.

Dec18
TOR Hacker,

Thanks for the reply. I'm not sure if I'm doing your first suggestion correctly? If I run "C:\Program Files (x86)\Tor Browser\FirefoxPortable\App\Firefox\tbb-firefox.exe -no-remote" I get the same error message as before. If I run the same command without the "-no-remote" switch, Firefox runs normally (without Tor). I'm not sure if that sheds any light on this problem.

I've also tried the changes in your second suggestion and played around with IntelligentStart and RunLocally true/false choices. Nothing seems to make any difference. I did notice the following lines in the FirefoxPortable.ini file:

"# The above options are explained in the included readme.txt
# This INI file is an example only and is not used unless it is placed as described in the included readme.txt"

Looking at the readme.txt, there is no explanation of anything and no description of the placement of "this INI file." These lines did prompt me to look around a bit and I found another FirefoxPortable.ini file here:

Tor Browser>FirefoxPortable>App>AppInfo>Launcher>FirefoxPortable.ini

This version looks quite a bit different than the first one, but I did try appending the -no-remote switch to first one, then the other, and finally to both of the lines containing an .exe file (Text in italics is what I added):

Start=FirefoxPortable.exe -no-remote
ProgramExecutable=Firefox\firefox.exe -no-remote

Unfortunately, nothing changed in the behavior of the browser launch.

One other thing I tried, on a hunch, was to launch the Tor browser as an administrator. Surprisingly (at least to me), it worked. I don't intend to run it this way as I'm guessing this is not a secure way to connect to the Internet?

I'm wondering if any of the data from the above experiments suggest a genuine solution?

Thanks again for your efforts to solve this problem.

Tom

Dec18
I use old version of Tor Browser for myself. And it is working OK for me.

But now I downloaded tor-browser-2.3.25-8_en-us.exe and also have questions.

First question is that there IS NO SUCH FILE "firefox.exe" anywhere in the package. So these lines in .INI make no sense:
ProgramExecutable=Firefox\firefox.exe
FirefoxExecutable=firefox.exe

There is tbb-firefox.exe instead. If you launch it directly, it will find your default Firefox installation & open it. Without Tor proxy, without security-specific plugins, without black color scheme.

So this is not "Another copy of Firefox", and not "Firefox Portable", this is something special and looks very strange.



Also, I have this file:

Tor Browser\FirefoxPortable\App\AppInfo\Launcher\FirefoxPortable.ini

As far as I can see, this is the file that comes with Firefox Portable from portableapps.com, and is an INI file for their PortableApps Launcher. The launcher itself is absent. Maybe this INI file was added mistakenly?


When I launch tbb-firefox.exe -no-remote I can see exactly the same window "Firefox is not responding". But when I run "start tor browser.exe" everything works fine. I am an Administrator, so I think this is exactly the same behavior that you described.

This looks very strange.

Dec18
Checked with filemon now, it doesn't look into Tor Browser\FirefoxPortable\FirefoxPortable.ini at all.

Here is complete list of *.ini files being accessed while launching "start tor browser.exe":

---
23:22:48 tbb-firefox.exe C:\TOR\Tor Browser\FirefoxPortable\App\Firefox\application.ini
23:22:48 tbb-firefox.exe C:\TOR\Tor Browser\FirefoxPortable\App\Firefox\platform.ini
23:22:48 tbb-firefox.exe C:\Documents and Settings\Administrator\Application Data\desktop.ini
23:22:48 tbb-firefox.exe C:\TOR\Tor Browser\FirefoxPortable\App\Firefox\crashreporter-override.ini
23:22:49 tbb-firefox.exe C:\TOR\Tor Browser\FirefoxPortable\Data\profile\compatibility.ini
23:22:49 tbb-firefox.exe C:\TOR\Tor Browser\FirefoxPortable\Data\profile\extensions.ini
---

All these processes (tor.exe, tbb-firefox.exe, polipo.exe) are run from vidalia.exe. "start tor browser.exe" only starts App\vidalia.exe & that's it, it doesn't do anything else.

So THE FILE you should edit is Tor Browser\Data\Vidalia\vidalia.conf


Now I wonder do I need TorBrowserBundle at all? I mean, much better way is to start Tor.exe directly & use it as Socks5 Proxy in your own Portable browser, installed especially for that purposes.

Dec18
TOR Hacker,

Thanks for the follow-up posts.

I tried editing the line containing tbb-firefox.exe in vidalia.conf to tbb-firefox.exe -no-remote. Maybe that was the wrong thing to do, as Tor exited unexpectedly with a few error messages. When I restored the original vidalia.conf file, the same problem occurred again with the same error messages. Rather than try to fix what appeared irretrievably broken, I just deleted the entire Tor Browser folder and ran tor-browser-2.2.25-10_en-US again. This time, rather than extract the files to the Program Files (x86) folder as before (I thought it would make sense to keep Tor with the other applications), I extracted them to the Documents folder. When I double-clicked on the Start Tor Browser icon, it worked. Could the location of the extracted files have been the problem all along? Whatever, for now at least all is working normally.

Thanks again for your help.

Tom

Reply

You are not logged in. Login or register to reply on this thread.