Tor control port doesn't work!

last year

Hi Guys,
It's now around 2 hours that I'm searching all over the net and can't solve this.
I run:
$ tor --controlport 9051

It says:
Mar 29 01:18:03.316 [notice] Tor v0.2.5.11 (git-cfb61f909a53c4eb) running on Linux with Libevent 2.0.22-stable, OpenSSL 1.0.2a and Zlib 1.2.8.
Mar 29 01:18:03.316 [notice] Tor can't help you if you use it wrong! Learn how to be safe at
Mar 29 01:18:03.317 [notice] Configuration file "/usr/local/etc/tor/torrc" not present, using reasonable defaults.
Mar 29 01:18:03.329 [warn] ControlPort is open, but no authentication method has been configured. This means that any program on your computer can reconfigure your Tor. That's bad! You should upgrade your Tor controller as soon as possible.
Mar 29 01:18:03.331 [notice] Opening Socks listener on
Mar 29 01:18:03.331 [notice] Opening Control listener on
Mar 29 01:18:03.000 [notice] Parsing GEOIP IPv4 file /usr/local/share/tor/geoip.
Mar 29 01:18:03.000 [notice] Parsing GEOIP IPv6 file /usr/local/share/tor/geoip6.
Mar 29 01:18:04.000 [notice] Bootstrapped 0%: Starting
Mar 29 01:18:04.000 [notice] We now have enough directory information to build circuits.
Mar 29 01:18:04.000 [notice] Bootstrapped 80%: Connecting to the Tor network
Mar 29 01:18:05.000 [notice] Bootstrapped 85%: Finishing handshake with first hop
Mar 29 01:18:06.000 [notice] Bootstrapped 90%: Establishing a Tor circuit
Mar 29 01:18:06.000 [notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Mar 29 01:18:06.000 [notice] Bootstrapped 100%: Done
^CMar 29 01:18:15.000 [notice] Interrupt: exiting cleanly.

But there is no control port and I cannot connect to it using a telnet program:
$ nmap

Starting Nmap 6.47 ( ) at 2015-03-29 01:29 CET
Nmap scan report for localhost.localdomain (
Host is up (0.0017s latency).
Not shown: 997 closed ports
22/tcp open ssh
631/tcp open ipp
9050/tcp open tor-socks

Nmap done: 1 IP address (1 host up) scanned in 0.29 seconds
$ nc forward host lookup failed: Unknown host

So my tor cannot open control port on 9051. It opens 9050 for the socks proxy. But no 9051, no control port. Tried 9151 also, but same result.
Please help.
Thanks in advance.


You are not logged in. Login or register to reply on this thread.